banner

Ebox T8 V not working

Paul Young


This topic contains 2 replies, has 2 voices, and was last updated by  Paul Young 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #88050

    Paul Young
    Participant

    Just received T8 V and is not working, as it only displays blue flickering light on the box. No time displayed and TV is not displaying a picture from the box.

    #88096

    Vik
    Keymaster

    Hello,

    Please try doing a factory reset on device using a Pin or Toothpick into Restore hole at device.

    Step 1 – Power off device
    Step 2 – Use a toothpick and press into Restore hole ( On side of device ) and keep it pressed.
    Step 3 – While holding reset button power on device
    Step 4 – Once you see boot menu on screen so release the reset button.
    Step 5 – Select wipe data / Factory reset on Recovery menu. Then reboot device now once its completed.

    #88097

    Paul Young
    Participant

    Boot screen does not appear.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Latest article


EBMC based on FTMC Kodi Jarvis for Android 4.4 users experience Kodi 17.3 Krypton

  August 18, 2017     EntertainmentBox     kodi

EBox H96 Pro Plus review Android 7.1.2, 3GB RAM 32GB ROM Amlogic S912

  July 30, 2017     EntertainmentBox    

Deepoon M2 Pro VR Headset Review, 3G RAM, 32G ROM, 75Hz, Exynos 7420

  July 15, 2017     EntertainmentBox     how to

How to update T8 V4 TV box from Android 5.1 to Android 6.1

  July 11, 2017     EntertainmentBox     how to